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Project 5 – Relational Databases (Access) 
 
 
Project Objective 
To operate efficiently and to remain competitive, it is essential for a company to manage its data 
appropriately.  Databases enable quick access to critical information; provide secure storage for 
sensitive data, and offer analysis/reporting tools for real-time decision making.  In addition, 
databases also play an important role with a company’s presence on the Internet.  Web-based 
databases have the ability to store information pertaining to customers, employees, competitors, 
online orders, and buying habits.  With this in mind, you realize it is a necessity to integrate a 
database into your existing IT infrastructure. 
 
In this project you will learn to use Microsoft Access to create a relational database, which is a 
type of database that has data organized into related tables.  This database will include tables 
that store the most common types of information pertinent to a corporation:  
 

• Employees 
• Customers 
• Products 
• Orders 

 
In addition to the tables, you will also setup the relationships between tables, and design input 
forms and queries (with formulas) plus create reports (also with formulas). 
 
Project Overview 
This project has been organized into 7 different parts: 

1. Creating a Flat File database in Excel 
2. Importing existing data from an Excel Spreadsheet 
3. Creating the Database Tables 
4. Establishing Table Relationships 
5. Generating Forms to Input Data 
6. Building Queries to Access Specific Data 
7. Creating a Report  
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Part 1 – Creating a Flat File Database 

In part 1, you will create a flat file database for storing some employee information.  Follow the 
instructions and samples listed below. 

 
1. Open Microsoft Office Excel 2010. 

2. Rename Sheet1 to Employees. 

3. Delete Sheets 2 & 3. 

4. In cells A1:K1, merge and center the following title:  Employees for Your Company.  Replace 
Your Company with your company’s name.  Format it how you want.  You may want to change 
the size, weight, and color. 

5. In cells A2:K2, enter the headings shown in Figure 7.  They are: No., Title, First Name, Last 
Name, Gender, Job Position, Salary, Address, City, State, Postal Code. 

6. Beginning in row 3, enter your own information for 10 employees.  Make sure you: 

a. have 5 female employees and 
b. only create 5 different job positions. 

7. Format the table of employees, including the headings in row 2.  Make sure you change the 
Salary column to currency and do not show a decimal point.  You may format the colors and 
such however you wish. 

8. Select the cells A2:K12.  In the Formulas tab, select the Define Name button.  For the name 
enter employeelist, and press the OK key.  This will name the range of cells that contain 
your field headers and data, so that you can easily refer to it later here and in other projects 
down the road. 

9. Save your workbook as lastname_firstname_excel_database.xlsx 
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Part 2 – Importing data from an Excel Spreadsheet 

In part 2, you will import data from the database created in part 1 into your Access database.  
Follow the instructions and samples listed below. 

1. Open Microsoft Office Access 2010. 

a) Click on Blank Database. 

b) Under the Blank Database section on the far right in the File Name textfield, enter 
lastname_firstname_access.  Click on the Browse icon to change the location to save 
your file.  It will append .accdb.  The Save as type is Microsoft Access 2007 
Databases (*.accdb). 

c) Click the Create button. 

2. From the top, click on the External Data tab.  Click on the Excel button. 

3. In the Get External Data window, use the Browse… button to locate and select the excel file 
you just created in part 1.  Select the Import the source data into a new table in the 
current database. option.  Click the OK button. 

4. In the Import Spreadsheet Wizard window:  

a) Select the Show Named Ranges radio button.  Select the range employeelist, which is 
the name range you created in your Excel project.  Select the Next > button to go to the 
next step in the wizard. 

b) Check the box First Row Contains Column Headings such that there is a checkmark 
there.  Click the Next > button. 

c) Select the No column in the table.  Under Field Options, change the Field Name to 
EmployeeNum.   Click the Next > button. 

d) Select the Choose my own primary key. radio button.  Using the pull-down, select the 
EmployeeNum option.  Click the Next > button. 

e) Note:  A primary key field is used to uniquely identify each record in your table. 

f) For the Import to Table textfield, enter EmployeesTbl.  Click the Finish button.  Click 
the Close button. 

5. Open your Employees table in Design View by clicking on the Home tab.  In the upper left 
corner, click on the View pull-down and select the Design View option. 

6. Delete the Gender and Salary fields by right clicking on the field row and selecting the Delete 
Rows option.  (Another way to delete is clicking on the field row and selecting the Delete option 
under the Records section in the Home tab.)  Click the Yes button to permanently delete the 
selected field. 

7. Add a new field to the table by typing Employee Status in the first empty cell in the Field Name 
column.  Set the Data Type to the Lookup Wizard… option. 

8. In the Lookup Wizard window: 

a) Select the I will type in the values that I want. radio button.  Click the Next > button. 

b) Under Col1, type in the following three options in the first three cells:  Full-time, Part-
time, and On-call.  Click the Next > button. 
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c) Checkmark the Limit To List checkbox.  Click the Finish button.  You have just created 
a Lookup Value for the Employee Status field. 

9. Save your changes by clicking on the Save icon (3.5” disk) in the top left corner of the Access 
window. 

10. Open the EmployeesTbl in the Datasheet View by clicking on the View pull-down and selecting 
the Datasheet View option.  (If you do not see the View pull-down, then click on the Home tab 
and you will see it in the upper left corner.) 

11. Add a status to each of your employees in the table.  To add a status, you can simply click in the 
Employee Status cell for each employee and utilize the lookup values provided by clicking on 
the pull-down menu. 

 
Note:  Your data is automatically saved each time you complete the editing of a record and 
move on to another record. 

12. When finished, close the table by right-clicking on the name EmployeesTbl and selecting the 
Close option. 
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Part 3 – Creating the Database Tables 

In part 3, you will create three additional database tables that will store Customer, Product, and 
Order Information.  Follow the instructions below to create the tables. 
 
Now, you will follow the steps below to create the Customers table that will store all customer-
related information (at least 10 entries).  Below is a sample customer table: 

 
1. Click on the Create tab and then click the Table Design option.  This will let us create a new 

table in Design View. 

2. Enter the following Field Names and Data Types. 

Field Name Data Type 
CustomerNum AutoNumber  
CustomerName Text 
Address Text 
City Text 
State Text 
Zip Text 
Telephone Text 
Fax Text 

3. Set up your key field by selecting the CustomerNum field and then selecting the Primary Key 
icon under the Design tab. 
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4. Save your table and name it CustomersTbl. 

 
5. Set up an Input Mask for the Telephone field.  An input mask specifies a pattern, e.g. (213) 740-

4542, for all data to be entered in the field. 

a) Click on the Telephone row in the CustomersTbl. 

b) Click on the General tab in the Field Properties section below the table. 

c) Click on the Input Mask row and then click on the   (Builder) button to start the Input 
Mask Wizard. 

d) In the Input Mask Wizard window, select the Phone Number option and click the Next > 
button. 

e) For the Input Mask, the textfield should have !(999) 000-0000 in it.  Click the Next > 
button. 

f) You can leave the default for storing the data.  Click the Next > button. 

g) Finally click the Finish button.  This will force everyone to use the same format for 
inputting this data, since it can be typed many different ways. 

6. Set up an Input Mask for the Fax field. 

7. Switch to Datasheet View and enter information for 10 customers.  Use the tab key to move 
from cell to cell.  Notice that CustomerNum is automatically entered. 

8. Close the table and the information will be saved automatically. 
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Now you will create a Products table for your products and their prices.  Here is a sample of 
what the ProductsTbl table will look like in Datasheet view: 

 
9. Create the Products table using the same tasks as you followed when creating the Customers 

table.  The Products table uses the following field names and data types: 

Field Name Data Type 
ItemNum AutoNumber 
ItemName Text 
RetailPrice Currency 

10. Make the ItemNum the Primary Key. 

11. Save the table and name it ProductsTbl. 
12. Switch to the Datasheet View and enter at least 7 different products into the table.   Then 

close the table. 



Page 8 of 8 
 

 

Create the Orders table that will store all order-related information.  This table will be linked to 
the previous tables.  Here is a sample of what the Orders table will look like: 

 
13. Create the Orders table using the same tasks as you have for the previous tables. The Orders 

table uses the following field names and data types: 

Field Name Data Type 
OrderNum AutoNumber 
OrderDate Date/Time 
ItemNum Number 
Quantity Number 
CustomerNum Number 
EmployeeNum Number 

14. Set the OrderNum as the Primary Key. 

15. Add an Input Mask for the OrderDate field and select the Short Date option. 

16. Save the table and name it OrdersTbl. 
17. Set up a Lookup Values for the ItemNum such that it will look up values for the ItemNum from 

the ProductsTbl. 

a) In the Design View, select the ItemNum field. 

b) Click on the Lookup tab below the Field Properties. 

c) For the Display Control, select the pull-down and choose the List Box option. 

 

Lookup 
Values 
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d) Set the following options: 

 
18. Set the Lookup Values for CustomerNum field as follows: 

 
19. Set the Lookup Values for the EmployeeNum field as follows: 

 
20. Switch to the Datasheet View and enter at least 6 different orders into the table.  Make sure 

there are at least 4 orders for March 2012. 

21. Save and close the table. 

CustomersTbl – The CustomerNum field is linked 
to the CustomerTbl 
 
1 – The column of the CustomerTbl which contains 
the information to put into the CustomerNum field 
 
2 – The number of columns to display 
 
0.25”;1” – The appropriate column widths to 
display information 

EmployeesTbl – The EmployeeNum field is linked 
to the EmployeesTbl 
 
1 – The column of the EmployeesTbl which contains 
the information to put into the EmployeeNum field 
 
4 – Display information from four fields: 
EmployeeNum, Title, First Name, and Last Name 
 
0.25”;0”;.75”;1” – Column widths, but set the 
second one to 0 so it won’t display the Title 

List Box 
 
ProductsTbl – The table to link to for information 
 
1 – The column of the ProductsTbl which contains 
the information to put into the ItemNum field 
 
2 – The number of columns to display information 
from the ProductsTbl when using the Lookup Value 
(pull-down) in Datasheet View 
 
0.25”;1” – The respective column widths to display 
information (the number of widths will match the 
Column Count) 
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Part 4 – Establishing Table Relationships 

Once you create your four tables with the appropriate number of fields, key fields and field 
attributes, you must set-up relationships between the tables including Enforce Referential 
Integrity.  Referential integrity is a set of rules that MS Access enforces to maintain consistency 
between related tables when you update data in a database. 
 
Next, you will establish relationships between the four tables.  Refer to the diagram shown 
below: 

 
1. Click the Database Tools tab and click on the Relationships option. 

2. Click on the Show Table button.  Select all four tables (use the Shift key to multiple select).  
Click the Add button. 

3. Arrange the tables as shown above. 

4. Click, hold, and drag the CustomerNum field in the CustomersTbl over the CustomerNum field 
in the OrdersTbl.  Let go. 

5. In the Edit Relationships window, checkmark the Enforce Referential Integrity checkbox.  
Click the Create button. 

6. Click, hold, and drag the ItemNum field in the ProductsTbl over the ItemNum field in the 
OrdersTbl.  Let go. 

7. In the Edit Relationships window, checkmark the Enforce Referential Integrity checkbox.  
Click the Create button. 

8. Click, hold, and drag the EmployeeNum field in the EmployeesTbl over the EmployeeNum 
field in the OrdersTbl.  Let go. 

9. In the Edit Relationships window, click on the Create button.  (Do not enforce referential 
integrity.) 

10. Click on the Close button to close the relationships and save your changes. 

11. You can test the relationships by trying to add an order for a non-existent customer. 
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Part 5 – Generate a Form to Input Data 

You will create an input form for adding a new customer and another input form for taking new 
orders. 
 
Now, you will create an input form for the Customers table.  Refer to the form shown below: 

 
1. Click on the Create tab. 

2. Click on the Form Wizard option. 

a) For the Tables/Queries option, use the pull-down to choose Table: CustomersTbl.  
Select all of the fields from the Customers table by clicking on the  >>  button.  Click the 
Next button. 

b) For the layout, select the Columnar radio button.  Click the Next button. 

c) For the title of your form, enter CustomersFrm.  Select the Modify the form’s design. 
option.  Click the Finish button. 

Because the Customer Number is assigned automatically, you wish to prevent the user from 
“clicking” within this field.  To “lock” this field, perform the following tasks in the Design view: 

3. Select the CustomerNum input field then click on the Property Sheet button under 
the Design tab.  The Property Sheet will be displayed on the right-hand side. 

4. In the Property Sheet, select the Format tab.  For the Back Style property, select the 
Transparent option.  For the Border Style property, select the Transparent option. 

 
5. In the Property Sheet, select the Data tab.  For the Locked property, select the Yes option. 
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6. In the Property Sheet, select the Other tab.  For the Tab Stop property, select the No option. 

7. You may adjust the formatting of the form and change the labels. 

8. Save your form. 

9. Select the View pull-down and select the Form View option.  You will see your new form. 

Create a second form called NewOrderFrm.  You will begin by using the form wizard as before, 
however, you will have to finish the form by performing some manual design tasks described 
below.  A sample form is shown here: 

 
10. Click on the Create tab. 

11. Click on the Form Wizard option. 

d) For the Tables/Queries option, use the pull-down to choose Table: OrdersTbl.  Select 
the following three fields:  OrderNum, OrderDate, and Quantity.  Click the Next button. 

e) For the layout, select the Columnar radio button.  Click the Next button. 

f) For the title of your form, enter NewOrderFrm.  Select the Modify the form’s design. 
option.  Click the Finish button. 

The next series of manual design tasks will explain how to add “Bound fields” (fields linked to 
data from tables) and “Combo Boxes” to your form.  You will also need to move, or rearrange 
some of the fields and their labels to resemble the sample shown above.  Here are some helpful 
hints for moving objects on your forms (and on your report that you will create later). 

Helpful design hints 

 
 

a. Field (Textbox objects) and their label objects are 
linked together 

b. If you wish to move both together as one unit, select 
the field object and place your cursor on the field’s 
border so the cursor’s shape becomes a 4 arrows. 

c. You can move the label object independently by 
moving this handle. 

d. You can move the field object independently by 
moving this handle. 

e. You can select more than one object by holding down the Shift key. 
f. You can align multiple selected objects by right clicking and choosing Align. 



Page 13 of 19 
 

12. Set the following properties (using the Property Sheet) for the OrderNum and OrderDate field 
objects: 

Tab Property Value 
Format Back Style Transparent 
Format Border Style Transparent 
Data Locked Yes 
Other Tab Stop No 

13. Set the following property for the OrderDate field object: 

Tab Property Value 
Data Default Value =Date() 

14. Arrange the three label/field groups, which are currently on your form, as shown in the sample at 
the top of the page. 

15. For the Customer Name and Customer Number, we want to add a combo box.  Under the 
Design tab in the Controls section, select the Combo Box icon. 

 
a) Drag and outline the location for the object on your form.  The Combo Box Wizard 

window will open. 

b) Select the I want the combo box to get the values from another table or query 
option.  Click the Next button. 

c) For the table or query question, select the Table: CustomerTbl option.  Click the Next 
button. 

d) Using the  >  button, add the following two fields:  CustomerNum and CustomerName.  
Click the Next button. 

e) Sort by CustomerName in Ascending Order.  Click the Next button. 

f) Checkmark the Hide key column checkbox.  Click the Next button. 

g) Select the Store that value in this field option and select CustomerNum.  Click the 
Next button. 

h) Enter Customer Name for the label.  Click the Finish button. 

i) In the Property Sheet, click on the Others tab and set the Tab Index property to 0. 

16. For the Employee Name and Employee Number, add a combo box by using the Combo Box 
wizard.  Use the same steps as above with the following exceptions: 

a) For the table, select Table: EmployeesTbl.  
b) Select the following two fields:  EmployeeNum and LastName. 

c) Sort by Last Name in Ascending Order. 
d) Store the value in the field EmployeeNum. 
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e) Label the field Employee Name. 

f) Set the Tab Index property to 1. 

17. For the Item, add a combo box by using the Combo Box wizard. 

a) For the table, select Table: ProductsTbl. 
b) Select the following two fields:  ItemNum and ItemName. 

c) Sort by Item Name in Ascending Order. 
d) Store the value in the field ItemNum. 

e) Label the field Item. 

f) Set the Tab Index property to 2. 

18. For the Quantity field, make sure the Tab Index property is set to 3. 

19. Save your form design 

20. View your Order Form in Form View. 

21. Use the New (blank) record icon at the very bottom of the form to add 4 more orders. 
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Part 6 – Build Queries to Access Data 

You will create two queries.  Both queries will extract data from at least two of the tables and sort the 
resulting information to be displayed.  Both queries will also include a formula. 

 
1. Click on the Create tab. 

2. Click on the Query Wizard option. 

a) In the New Query window, select the Simple Query Wizard option.  Click the OK 
button. 

b) For the Tables/Queries option, select Table: OrdersTbl.  Select the following two fields:  
OrderDate and Quantity. 

c) For the Tables/Queries option, select Table: ProductsTbl.  Select the following two 
fields:  ItemName and RetailPrice.  Click the Next button. 

d) Select the Detail radio button.  Click the Next button. 

e) For the title of your query, enter Orders for March Query.  Select the Modify the query 
design. radio button.  Click the Finish button. 

3. Select the Quantity column and drag it between the ItemName and RetailPrice columns. 

4. Within the OrderDate column, set the Criteria for the query by typing Between #3/1/12# 
And #3/31/12# in the cell on the Criteria row. 

5. Sort the information by date by selecting Ascending from the pull-down on the Sort row within 
the OrderDate column. 

6. Add a new column of information for the Total.  On the Field row in the first black column, enter 
the following:  Total:[Quantity]*[RetailPrice] 
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7. Switch to the Datasheet View to view the query results. 

 
Create a second query to list orders by customers.  A sample is shown here. 

 
8. Using the Simple Query Wizard, create a query named Orders by Customers Query. 

9. The fields for your query will be taken from three tables: 

Table Field 
CustomersTbl CustomerNum 
CustomersTbl CustomerName 
OrderTbl ItemNum 
OrderTbl Quantity 
ProductsTbl RetailPrice 

10. Create a field for Total and use an appropriate formula to calculate the price. 

11. Place the columns of information in the order shown in the sample above. 

12. Sort the information by both customer name and total price.  The CustomerName should be 
sorted in Ascending order and the Total in Descending order. 

13. Switch to the Datasheet View to view the query results. 
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Part 7 – Create a Report 

You will create one report that collects at least one field of data from three of the tables.  
Formulas will be used to keep a running total and to calculate a grand total for the report.  The 
name of your report will be lastname firstname created mm/dd/yy. 

You will create a report of Accounts Receivables, in landscape format, using the Reports 
Wizard.  Add formulas for Totals, Running Totals, and a Grand Total.  You may want to review 
the helpful design hints given in Part 4. 

 
1. Click on the Create tab. 

2. Click on the Report Wizard. 

a) The fields for your query will be taken from three tables.  Add them in the following order: 

Table Field 
CustomersTbl CustomerName 

ProductsTbl ItemName 

OrdersTbl Quantity 

ProductsTbl RetailPrice 

b) For viewing the data, select by OrdersTbl. 
c) For sorting, select CustomerName in Ascending order. 

d) For the Layout, select Tabular. 
e) For the Orientation, select Landscape. 

f) For the Title, enter lastname firstname created mm/dd/yy. 

g) Select the Modify the report’s design before clicking on the Finish button. 

3. Add the Total label to your report using the Label tool.  

a) Click on the Design tab.  In the Controls section, select the Label icon (Aa). 
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b) Draw the label object within the Page Header section of the report. 

c) In the Label box, enter Total. 
d) Adjust the size and location of the new object. 

4. Add the Total field to your report using the Text Box tool.   

a) In the Design tab in the Controls sections, select the Text Box icon. 

b) Draw the field object within the Detail section of the report. 

c) Access created a Text label within the Detail section.  Delete this Text object by right-
clicking on it and selecting the Delete option. 

d) Select the new Unbound control object.  In the Property Sheet, select the Data tab.  Set 
the Control Source property to =[Quantity]*[RetailPrice] 

e) In the Property Sheet, select the Format tab.  Set the Format property to Currency. 

f) Adjust the size and location of the new field object as shown in the sample. 

5. Add the Running Total objects to the report by adding a Label in the Page Header section and 
a Text Box in the Detail section. 

a) Repeat steps 3 and 4 you did for the Total label and Total field. 

b) Additionally, for the Running Total field object, in the Property Sheet in the Data tab, set 
the Running Sum property to Over All. 

6. Update the Page Footer section. 

a) Remove any objects that are currently in the Page Footer section. 

b) Add a horizontal line to the top of the section.  In the Design tab in the Controls section, 
use the Line option.  You can format it by selecting on the Format tab. 

c) Add a Grand Total text box.  For the Grand Total label, change the text to Grand Total. 
d) Select the Grand Total field object.  In the Property Sheet, select the Data tab. Set the 

Control Source property to the name of the Running Total field object.  For example:  
=[Text15] 
Note: your text number may be different.  Check the Name property of the Running Total 
object on your report to get the correct name. 

e) In the Property Sheet, select the Format tab and set the Format property to Currency. 

7. In the Report Header section, change the title of the report to Accounts Receivable by your 
name 

8. Switch to the Report View and verify that your report resembles the sample and that all values 
are calculated and displayed properly. 

9. Return to the Design View to make any necessary corrections. 

10. Save and close the report. 
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Submitting the project 

1. Your excel file should have one sheet with the flat file database.  Your Access file should have 
one database with four tables (CustomersTbl, EmployeesTbl, OrdersTbl, ProductsTbl), two 
queries (Orders by Customers Query, Orders by October Query), two forms (CustomerFrm, 
NewOrderFrm), and one report (lastname firstname created date). 

2. You need to submit your Access file (lastname_firstname_access.accdb) and your Excel file 
(lastname_firstname_excel_database.xlsx).  Put them in the same folder. 

3. Use a zip program such as 7-Zip and zip them into one file named 
lastname_firstname_access.zip.  This is the file that you will submit on Blackboard. 

4. Submit your zip file on Blackboard (http://blackboard.usc.edu) under Assignments: 

a. Click on the Lab5 assignment. 
b. Next to Attach File, click on the Browse My Computer button. 
c. Find your lastname_firstname_access.zip file and click the Choose button. 
d. Click on the Submit button in the bottom right corner. 

 


